Opened 8 years ago

Closed 7 years ago

#8043 closed bug (duplicate)

Resizable containment stops working when helper is defined

Reported by: alfatek Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.resizable Version: 1.8.17
Keywords: Cc:
Blocked by: Blocking:

Description

I have a div that is resizable and is inside a bigger div which is the containment element defined. When I resize the div outside the containment box nothing happens, as predicted (size is restricted by containment box)

When I also define an helper class the containment stops working as the size is not restricted by the containment box. If you try to resize it outside the containment box my div is resized without constraint.

Examples: Working ok: http://jsbin.com/ivevad/2/

Not working correctly: http://jsbin.com/ocezic/2/

In both of them, try to resize horizontally past the containment box (red border).

Change History (3)

comment:1 Changed 8 years ago by alfatek

Tested in chrome windows 16.0.912.75 m and FF 3.6.25.

Also samples are provided using jquery ui 1.8.13 but the problem is still there in 1.8.17

Working: http://jsbin.com/ivevad/3

Problem: http://jsbin.com/ocezic/4

Last edited 8 years ago by alfatek (previous) (diff)

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #8044.
This is essentially the same problem as #8044. I'll comment in that issue to make sure it mentions both issues.

Note: See TracTickets for help on using tickets.