Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8047 closed bug (duplicate)

Object is not deactivate

Reported by: imthehell Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.core Version: 1.8.17
Keywords: Cc:
Blocked by: Blocking:

Description

After the drop function is executed, if the accept function of the object no longer return true (because the drop function has changed some paramenters of the dragged object like class ecc.) the object is not deactivated. The problem is this "if":

 if (!this.options.disabled && this.visible && this.accept.call(this.element[0], (draggable.currentItem || draggable.element))) {
                    this.isout = 1; this.isover = 0;
                    this._deactivate.call(this, event);
                }

the only objects that will be deactivated are those whose the accept function return true. If the accept function no longer return true they remain activated. It should, however, disable all objects in all cases.

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by Scott González

Duplicate of #8046.

Note: See TracTickets for help on using tickets.