Opened 8 years ago

Closed 7 years ago

#8112 closed bug (invalid)

Show/Hide with "Slide" Animation - Height Issue

Reported by: streetlogics Owned by: streetlogics
Priority: minor Milestone: 1.10.0
Component: ui.effects.* (individual effect) Version: 1.8.17
Keywords: Cc:
Blocked by: Blocking:

Description

I have posted the details of the issue I'm having to Stackoverflow - http://stackoverflow.com/questions/9216736/jquery-ui-show-hide-with-slide-animation-height-issue#comment11606036_9216736 , but will repost them here as well:

I have a list of items, and some of the items have an additional list of items inside of the <li> . I have created a function that lets you "show/hide" the list of items using the jQuery UI show('slide') method. The problem I'm having is that the container gets the height set before the "show" slide action, and the container stays at the full height during the "hide" slide action until the animation is complete. I have created a JSBin showing this issue, and am hoping someone can help me figure out how to get the slide to smoothly transition the height instead of the current "full-height" problem. During my testing, I have discovered that using .show('slide', {direction:'up'}) does not yield the same results as .slideDown(); , which I would have expected to do the same thing. The JSBin has two links that showcase this; "Ugly slide" uses .show(...), and "Smooth slide" uses .slideDown() . I think this might be a bug in jQuery UI in the show+animation method vs. the "pure" UI slideDown/slideUp methods.

http://jsbin.com/utijec/4/edit#javascript,html,live

Change History (5)

comment:1 Changed 8 years ago by Scott González

Component: effects.coreeffects.* (individual effect)

comment:2 Changed 7 years ago by bernhardsirlinger

I checked the effects and found out that the slideDown and slideUp animations are similar to the show('blind') and hide('blind').
The show('slide') effect slides the element from left to right, which is the reason for the unexpected behaviour in your test case.
But eventually there could be a bug with the options because the directions are not recognized. This could also be intentionally, because the 'blind' effect provides the function similar to the slideDown and slideUp methods.

comment:3 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:4 Changed 7 years ago by mikesherov

Owner: set to streetlogics
Status: newpending

Thanks for contributing! It looks like this was fixed by the core animation rewrite: http://jsbin.com/utijec/12 . Please let me know if these results match your expectation. Thanks!

comment:5 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.