Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8151 closed bug (duplicate)

Setting a dateFormat without the year makes getDate always return the current year

Reported by: nfm Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.16
Keywords: Cc:
Blocked by: Blocking:

Description

With dateFormat set to 'D dd M', and a date from the previous year selected (eg 1 Jan 2011), getDate will incorrectly return the current year (eg 1 Jan 2012).

This is inconsistent with altField, and makes it impossible to programmatically get the date with correct year from the datepicker.

I believe this still affects 1.8.18, but jsFiddle only currently has 1.8.16.

Change History (3)

comment:1 Changed 9 years ago by nfm

Link to test case:

http://jsfiddle.net/PcCXV/

(Aside: flagging submissions as spam if they contain links is total insanity.)

comment:2 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by Scott González

Duplicate of #7759.

Note: See TracTickets for help on using tickets.