Skip to main content

Search and Top Navigation

#8203 closed feature (fixed)

Opened March 19, 2012 11:23PM UTC

Closed October 27, 2015 01:50PM UTC

Last modified November 04, 2015 04:30AM UTC

Button: Deprecate text option; rename to showLabel

Reported by: sp2 Owned by:
Priority: blocker Milestone: 1.12.0
Component: ui.button Version: 1.8.18
Keywords: Cc:
Blocked by: Blocking:

Using 'text' as a boolean to control whether or not the button label is shown isn't very intuitive. It also could easily conflict with other frameworks that might use 'text' to set the label of a variety of controls. Can we change the name to something a little more descriptive, like 'showLabel' or 'showName'?

Attachments (0)
Change History (7)

Changed June 26, 2012 01:24AM UTC by scottgonzalez comment:1

type: enhancementfeature

Changed September 01, 2012 10:19AM UTC by bernhardsirlinger comment:2

I already opened a pull request on GitHub fixing this issue.

Changed October 11, 2012 02:43PM UTC by scottgonzalez comment:3


Changed October 15, 2012 09:29PM UTC by tj.vantoll comment:4

status: newopen

We'll look at this when button's API is readdressed in 1.11.

Changed April 01, 2014 06:02PM UTC by scottgonzalez comment:5

milestone: 1.11.0none

Changed October 27, 2015 01:50PM UTC by scottgonzalez comment:6

milestone: none1.12.0
resolution: → fixed
status: openclosed
summary: 'text' is a confusing name for the optionButton: Deprecate text option; rename to showLabel

Changed November 04, 2015 04:30AM UTC by scottgonzalez comment:7

priority: minorblocker