Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8239 closed enhancement (duplicate)

Event handlers don't work in Google Sites' HTMLBox

Reported by: metaweta Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.18
Keywords: Cc:
Blocked by: Blocking:

Description

Google Sites allows people to use HTML and JavaScript and transforms it to be safe. It throws away dynamically-generated JavaScript, so the onclick and onchange handlers get stripped. If the event handler code was supplied beforehand and the generated HTML nodes were labeled with an attribute that told which event handler to apply, a pass over the static nodes could attach them and allow datepicker to work on Sites.

A CL on github is in preparation.

Change History (4)

comment:2 Changed 8 years ago by metaweta

That commit is also a fix for 3945.

comment:3 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:4 Changed 8 years ago by Scott González

Duplicate of #3945.

Note: See TracTickets for help on using tickets.