Opened 10 years ago

Closed 10 years ago

#8240 closed feature (wontfix)

No easy/good way to have an inline datepicker WITH a textbox

Reported by: philfreo Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.18
Keywords: Cc:
Blocked by: Blocking:

Description

There's no easy/good way to have a datepicker that appears inline (as if you would say $('#someDiv').datepicker()) AND also have a textbox that controls the date as if you said $('#someInput').datepicker().

altField is close but doesn't quite cut it. When you say $('#someDiv').datepicker({ altField:'#someInput' }), the problem is that typing a date into the #someInput textbox doesn't update the date.

I think a good solution would be to be able to say: $('#someInput').datepicker({

inline: '#someDiv'

})

(The new inline option would default to null, which means "auto", based on if the element is an input or a div/span, like it does currently.)

Change History (1)

comment:1 Changed 10 years ago by Scott González

Resolution: wontfix
Status: newclosed

Just create an inline datepicker and manually wire the text field to it. It's only a few lines of code...

Note: See TracTickets for help on using tickets.