Opened 5 years ago

Closed 5 years ago

#8244 closed bug (duplicate)

with jQuery 1.7.2 - iframe inside jquery dialog reloads content multiple times

Reported by: Zwonimir Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.dialog Version: 1.8.18
Keywords: Cc:
Blocked by: Blocking:

Description

Hi all! I discovered this bug and somebody else on the net has the same problem but he didn't solve it:

i have an iframe inside a jquery dialog, and the dialog has some flashy animations when showed and hided:

$('#dialog_div').dialog({ autoOpen: false
, modal: true, show: 'clip', hide: 'clip', width: 600, height: 350});

$('#dialog_div').dialog('open');
$('#dialog_iframe').attr('src', 'content.aspx');

the problem is that the page "content.aspx" loads two times when I open the dialog and two times when I close the dialog with the command "$('#dialog_div').dialog('close');".

I found that the problem is the animation applied on the dialog, because if I remark the options "show: 'clip', hide: 'clip'," of the dialog the iframe fires only one time when I show the dialog.

Thanks! Zwonimir

Change History (4)

comment:1 Changed 5 years ago by Scott González

Related to #5166.

comment:2 Changed 5 years ago by Zwonimir

With this advice:

In the html source, set the src of the iframe to 'about:blank' or 'javascript:false'.
Create dialog with {autoOpen:false}.
Set the src of iframe.
Open the dialog.
Before destroying, Set the src to blank.

i get rid of page reloading when I close the dialog, but the page still loads 2 times when I open the dialog.

comment:3 Changed 5 years ago by Scott González

Milestone: 1.9.01.10.0

comment:4 Changed 5 years ago by drewkimrey

Resolution: duplicate
Status: newclosed

Duplicate of #5166.
Same issue as #5166

Note: See TracTickets for help on using tickets.