Opened 10 years ago

Closed 10 years ago

#8251 closed bug (wontfix)

only IE8 bug if adding html or text in .ui-slider-handle on the event slide

Reported by: arxwn Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.slider Version: 1.8.18
Keywords: Cc:
Blocked by: Blocking:

Description

Hello there is a strange bug that is only happening on IE8 not IE7 or IE9 preventing the user to slide the slider by clicking and moving the mouse to desired position.

For example: I use the slide event and on slide change event i put some text on the slider button because i want to display a numeric value on the little slider.

slide: function( event, ui ) {

$( "#slider .ui-slider-handle").html('<div class="sliderClass">'+ui.value+'</div>');				
			
}

Note: This bug happens only on Internet Explorer 8 not IE7 or IE9

Change History (3)

comment:1 Changed 10 years ago by arxwn

Check an example: on jsfiddle: http://jsfiddle.net/aYxqh/ Try to scroll the slider with INTERNET EXPLORER 8 to see what happens...

comment:2 Changed 10 years ago by tj.vantoll

I can recreate this in master. The issue is occurring because it's going into this code block in the _mouseMove function in jquery.ui.mouse.js:

// IE mouseup check - mouseup happened when mouse was out of window
if ($.browser.msie && !(document.documentMode >= 9) && !event.button) {
    return this._mouseUp(event);
}

event.button switches from 1 to 0, causing _mouseMove to return and never call _mouseDrag. I do not know what would cause the value to change. I was able to find an old forum entry that mentions the same issue - http://forum.jquery.com/topic/problems-with-ie8-and-ui-sortable.

comment:3 Changed 10 years ago by Scott González

Resolution: wontfix
Status: newclosed

I'm not sure that we should/can do anything about this. See http://jsfiddle.net/aYxqh/2/

Note: See TracTickets for help on using tickets.