Opened 7 years ago

Closed 7 years ago

#8263 closed bug (fixed)

Autocomplete does not display results on Android in Firefox unless you delete

Reported by: jaredwilli Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.18
Keywords: Cc:
Blocked by: Blocking:

Description

I have been using Samsung's Galaxy Tab with Android 3.2 and running Firefox 10.

I noticed that autocomplete does not work when using this setup, I'm not sure if a different android or firefox version # works differently or not.

When you type in a search box which uses Autocomplete, such as the demo page on this site for example, you are not able to see results for the letters typed unless you type a few, and delete the last letter, then the drop down of matched results shows up.

I have not tested this with anything besides the Galaxy Tab, but I imagine it might be specific to android running firefox, since it is working fine when using the default android browser on the Tab.

Change History (1)

comment:1 Changed 7 years ago by Scott González

Resolution: fixed
Status: newclosed

The problem is that Firefox is not sending keydown, keypress, or keyup events when typing. It does, however, send input events. Master already has support for input events, so this is working on master.

Note: See TracTickets for help on using tickets.