Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8278 closed bug (duplicate)

The "document.ready" function inside a toggle div gets executed twice

Reported by: Kruellos Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.core Version: 1.8.19
Keywords: Cc:
Blocked by: Blocking:

Description

As the summary says, the document.ready functions inside a div that is being toggled gets executed twice.

I've made a little demo page: http://jsfiddle.net/Daveloose/9pDET/2/

We try to bind events inside, but they get binded twice. So a work around is first to unbind, and then to bind. Is this a bug? Or is this the implementation? I consider this as a bug.

Kind regards!

Change History (3)

comment:1 Changed 7 years ago by Kruellos

I just noticed if you toggle without any slide effect it just works.

You can check it out: http://jsfiddle.net/Daveloose/9pDET/11/

Last edited 7 years ago by Kruellos (previous) (diff)

comment:2 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:3 Changed 7 years ago by Scott González

Duplicate of #3677.

Note: See TracTickets for help on using tickets.