Opened 7 years ago

Closed 6 years ago

#8284 closed feature (invalid)

slidecreate event - ui.value is undefined

Reported by: enumag Owned by: enumag
Priority: minor Milestone: 1.11.0
Component: ui.slider Version: 1.8.20
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/NPx4z/1/

The initial value is already set by .slider( ... value: 10 }, then why is it not available in slidecreate event handler?

Change History (5)

comment:1 Changed 7 years ago by Scott González

Type: bugfeature

This is not a bug. Widgets weren't designed to provide any data in create, because everything is already available via the options. However, we have started adding data in cases where it would make reusing event handler easier. In this case, a stop or change handler could be doubled up on create.

Last edited 7 years ago by Scott González (previous) (diff)

comment:2 Changed 6 years ago by Scott González

Milestone: 1.9.01.11.0

comment:3 Changed 6 years ago by tj.vantoll

Status: newopen

Verified that this is still an issue in 1.9 - http://jsfiddle.net/tj_vantoll/A6xf4/. It does seem like the value would be useful to have in a create method.

comment:4 Changed 6 years ago by Scott González

Owner: set to enumag
Status: openpending

Actually, I'd like to know what the use case is, since the value can be queried pretty easily.

comment:5 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.