Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8305 closed bug (duplicate)

Drag-clicking on checkbox/buttonset doesn't register as click

Reported by: Uri Gilad Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.button Version: 1.8.20
Keywords: Cc:
Blocked by: Blocking:

Description

The problem happens when using .buttonset() on radios or checkboxes, or just .button() on a checkbox. If the mousedown occurs on the button, then drag (a little or a lot), then mouseup while still over the button, the button will not get clicked.

Example: http://jsfiddle.net/antishok/pn7xP/ (Those are straight from the jqui examples)

Since these are buttons/buttonsets, I believe they should behave like them with regards to these drag-clicks. Some people also have "sloppy" clicks which might drag a bit before the mouseup, and then it doesn't get clicked as they would expect (and then they blame me! otherwise I probably wouldn't have filed a ticket)

Cheers!

Change History (3)

comment:1 Changed 8 years ago by Uri Gilad

This issue was also referenced to here: http://bugs.jqueryui.com/ticket/6970

comment:2 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:3 Changed 8 years ago by Scott González

Duplicate of #7665.

Note: See TracTickets for help on using tickets.