Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8309 closed bug (duplicate)

Autocomplete showing once only in Chrome

Reported by: rahal Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.20
Keywords: Cc:
Blocked by: Blocking:

Description

I have a simple autocomplete that works correctly in FF and IE. In Chrome it works the first time text is typed into the 'City' input. If the text is changed or deleted the drop down does not appear.

$('#City').autocomplete({

source:CityName, delay:400

});

If I do this so that the search triggers on focus it works correctly in FF and IE (dropdown opens on focus and search is performed). In Chrome the dropdown displays but an item cannot be selected.

$('#City').autocomplete({}).focus(

function(){

$(this).autocomplete('search');

});

The "source" is created dynamically before the autofocus is created but for testing I am using this:

var CityName=[ 'Koh Samui, Thailand', 'Krabi, Thailand', 'Phuket, Thailand'];

Change History (2)

comment:1 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by Scott González

Duplicate of #8308.

Note: See TracTickets for help on using tickets.