Opened 8 years ago

Closed 7 years ago

#8335 closed bug (wontfix)

Draggable: reports different coordinates for SVG element in Firefox and Webkit

Reported by: rrt Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.draggable Version: 1.8.20
Keywords: Cc:
Blocked by: Blocking:

Description

Please see the example at http://jsfiddle.net/rrthomas/v477X/11/

When the black rectangle is dragged, the coordinates reported to the drag event are relative to the svg element in Webkit, and relative to the rect element being dragged in Firefox. The browser-specific code patches this up, but it looks like jQuery(UI) is reporting different coordinates in the two browsers.

Note that the jsFiddle uses jQueryUI 1.8.18 because that's the newest available on jsFiddle, but I have also tested with 1.8.20 and reproduced the problem there.

Change History (2)

comment:1 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:2 Changed 7 years ago by mikesherov

Resolution: wontfix
Status: newclosed
Summary: Draggable reports different coordinates for SVG element in Firefox and WebkitDraggable: reports different coordinates for SVG element in Firefox and Webkit

Thanks for contributing! Unfortunately, jQuery doesn't support SVG: http://docs.jquery.com/Won't_Fix#SVG.2FXML.2FVML_Bugs and as such, I'm marking this as won't fix.

Note: See TracTickets for help on using tickets.