Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8376 closed bug (notabug)

dialog box breaking in chrome and ie, displays fine in FF and Safari

Reported by: dgodfrey0724 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.20
Keywords: Cc:
Blocked by: Blocking:

Description

dialog box works fine in FF and Safari, then breaks in IE and Chrome (latest versions)

checked tickets in here, and even seen one stating it's a non-issue LOL /facepalm

is there a work around?

site is internal+password protected, so sending u the links to the live pages is about as beneficial as giving an empty water bottle to someone in the desert - however, i do have screenshots... just no where to post them for them to be accessible here... dropbox? >.<

code: in .aspx:

<div id="dialog-form" title="Create new asset">

<form>

<fieldset>

<label for="fname">File Name</label> <input type="text" name="fname" id="fname" class="text ui-widget-content ui-corner-all" value=""/><br> <label for="filetype">Video Type</label> <select name="filetype" id="filetype" class="text ui-widget-content ui-corner-all"></select>

</fieldset>

</form>

</div>

in .js: (...previous code of function...)

$( "#dialog-form" ).dialog({

autoOpen: false, height: 300, width: 500, modal: true, buttons: {

"Add New Asset File": function() {

var bValid = true; allFields.removeClass( "ui-state-error" ); alert('filename='+fname.val());

if ( fname.val() ) {

allAssets=""; nextasset='<div id="asset'+assetcntr+'">'; chkselect= fname.val(); nextasset+='<input type="text" id="assetURL'+assetcntr+'" name="sURL'+assetcntr+'" value="'+chkselect+'">'; asset URL

chkselect= filetype.val(); nextasset+='<select id="sFormat'+x+'" name="vidformat'+x+'" >'; jQuery.each(Options_AF_sFormat, function(i, val){

if(val.sKey == chkselect){

nextasset+='<option value="' + val.sKey + '" selected="selected">' + val.sName + '</option>'; asset video format type (.flv, .swf, .avi, .mpeg, etc)

}else{

nextasset+='<option value="' + val.sKey + '">' + val.sName + '</option>';

}

}); nextasset+='<input type="button" id="deleteme'+assetcntr+'" onclick="deleterow('+assetcntr+')" value="Remove"></div>'; delete line button

allAssets+=nextasset;

$divID.find("#assetfilelisting").append(allAssets); $("#deleteme"+assetcntr).button(); $( this ).dialog( "close" ); assetcntr++;

}

}, Cancel: function() {

$( this ).dialog( "close" );

}

}, close: function() {

allFields.val( "" ).removeClass( "ui-state-error" );

}

});

$( "#create-asset" ).click(function() {

$( "#dialog-form" ).dialog( "open" );

});

$("#submitbttn").button(); $("#create-asset").button(); $("#add-ad").button(); $("#rmv-ad").button();

} function deleterow(x){

alert('ive been triggered - asset #'+x+'to be deleted'); $divID=$('.edit_video'); $divID.find("#asset"+x).remove();

}

then ofcourse all of the jquery ui code in it's own .js(update downloaded literally 2 days ago)for the dialog box, and .css beautification code that goes for the entire site...

Change History (14)

comment:1 Changed 7 years ago by Scott González

Resolution: invalid
Status: newclosed

You don't even describe the bug. Either use the forums or StackOverflow for help or provide a live reduced test case showing the problem (and explain what is actually broken).

comment:2 Changed 7 years ago by dgodfrey0724

....rude much? fine, now u get my frustrated old school coder voice:

what part of BROKEN is not understood? translation: IT DOESN'T WORK! IT'S NOT DISPLAYING! OVERLAY DOESN'T EVEN COME UP! i don't have time to state EVERY single thing it ISN'T doing in IE or Chrome - something in the code i was INSTRUCTED to copy and paste from YOUR site is BUSTED. if i HADN'T been TOLD to use YOUR stylized js, i would have HANDCODED it MYSELF and not be asking YOU what is WRONG. you're lucky i can't reach through here and smack you upside the head with a nerf sword!

*takes a deep breathe* however, that doesn't resolve the issue at hand - so instead i will try to list a FEW of the errors i'm experiencing: it DOESN'T display in IE - AT ALL - just the 'create asset' button - click all day long on it and NADA - no popup widget, no overlay, NOTHING

as for chrome, it puts the input text box, select box, and labels all at the top right of the live web page, without ever clicking on the 'create asset' button that would trigger the dialog box, but doesn't display the submit/cancel buttons, and clicking the 'create asset' button doesn't bring up overlay, move the inputs to the pretty little display box, show the submit/cancel buttons, nada.

and just to repeat, it works PERFECTLY FINE in FF and Safari - no errors whatsoever in firebug

how's that for 'describing the bug' /growl&glare

comment:3 Changed 7 years ago by dgodfrey0724

and if you give me somewhere to send them, i can send you screenshots of the errors - as i stated to begin with, putting the urls in here is worthless, the site is internal to the company and password protected

comment:4 Changed 7 years ago by dgodfrey0724

it should also be noted that the datepicker/datetimepicker widget works fine in all four browsers... in the same form

comment:5 Changed 7 years ago by dgodfrey0724

ok - looking for some kind of response - not expecting the solution right this second, but at least confirmation someone has read my additional comments... and no - i DON'T want to leave this ticket closed (radio button fail - only 1 option - or extremely rude if that is intended code) - however, don't think i won't create a NEW ticket just to get some resolution to this - creating new accts and copy/paste can work wonders...

comment:6 Changed 7 years ago by Scott González

You won't get a response until you provide a reduced test case.

comment:7 Changed 7 years ago by dgodfrey0724

where would u like me to send the screenshots then? or the code?

comment:8 Changed 7 years ago by Scott González

I don't want screenshots, I want code, as has been stated multiple times. If you would calm down for a few minutes and read the red box, you would know that you should use jsFiddle or jsbin to provide test cases.

comment:9 in reply to:  5 Changed 7 years ago by Corey Frang

Replying to dgodfrey0724:

however, don't think i won't create a NEW ticket just to get some resolution to this - creating new accts and copy/paste can work wonders...

Threatening to spam a bug tracker is not the way to get anyone to pay attention to your problem.

This ticket was closed as invalid because we can't investigate the cause of your problem without a reduced test case. Since you state that the other widgets work correctly in the same environments, I'm inclined to believe that the bug is not within UI itself but the code surrounding your calls to UI.

Without a reduced case to show the problem, we don't know for sure.

Last edited 7 years ago by Corey Frang (previous) (diff)

comment:10 Changed 7 years ago by dgodfrey0724

and yet you responded LOL, which validates someone is still getting alerted whenever i add more content to this ticket - it's called testing to see if 'closed' is the same as 'talking to oneself in an empty void no one is able/or cares to see'

but ty for clarifying exactly what info you need, and how to submit it - i'm @ home now, but i do have snippets of the code i tried to send via email, which i started banging my head against the wall when i realized that email address was not a valid recipient >.<

and i was calm, till the first replier just slammed me without clarifying why or even offering the info you did

now to try to post the code to fiddle... hope i do this right, and hope it's enough code for ya'll to see the errors i am...

comment:11 Changed 7 years ago by dgodfrey0724

http://jsfiddle.net/Xrru5/3/

ok - it's only missing the jquery ui part - and ofcourse the values from the database for the autofill, but ohwell

comment:12 Changed 7 years ago by Scott González

Seriously? We need a reduced test case. Not 2,000 LOC JS + HTML 5 Boilerplate + C#...

comment:13 Changed 7 years ago by dgodfrey0724

lol - that IS the reduced - the site is MUCH larger than that ONE displayed page - if you would like an even more concise section - go back to the TOP of this thread, to my orig post... with the jsFiddle though, in the js section, the edit tab starts at @line 1040 - the rest of that js is needed from function calls to generate and display the sections of the page - as it is, the page is only partially showing - those sections should be coming up as tabs, with requirement for admin login to even see the edit video section - but i didn't include the jquery ui code from your site, or the force the database connection - you did ask for REDUCED functioning test - so... TAADAA

comment:14 Changed 7 years ago by dgodfrey0724

found it (amazing what a weekend break followed by lots of caffiene can do)- ie achilles heal, form inside a form to blame (which FF and Safari ignore)/facepalm - might want to add a note on that to the demo site - can't just remove the inside form tags either, have to move the ENTIRE div set outside of the other form - also added 'return false;' to the .display("open") call, and made the id references more specific - updated code at: http://jsfiddle.net/Xrru5/6/

Note: See TracTickets for help on using tickets.