Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#8424 closed bug (notabug)

Datepicker error with IE9 and swf object tag

Reported by: deopard Owned by: deopard
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.21
Keywords: Cc:
Blocked by: Blocking:

Description

Hi I a using a datepicker and swfupload component.

Don't know if I should it right it in jquery core ticket. So this is when the bug happens

  1. Open the datepicker
  2. Click on the swfUplad's upload button (Which is an object tag with several param tags inside which looks like this.)

<object id="SWFUpload_0" type="application/x-shockwave-flash" data="/Content/swfupload.swf?preventswfcaching=1341379483354" width="109" height="22" class="swfupload"> <param name="wmode" value="transparent"> <param name="movie" value="/Content/swfupload.swf?preventswfcaching=1341379483354"> <param name="quality" value="high"><param name="menu" value="false"> <param name="allowScriptAccess" value="always"> .... others </object>

An exception "Missing instance data for this datepicker" occurs when I click on the object. It doesn't happen in ff, chrome, ie 7 and ie 8. When I debug the source, it looks like the errors happen when it tries to return the data value binded to the object by using $.data.

Change History (9)

comment:1 Changed 7 years ago by Scott González

Owner: set to deopard
Status: newpending

Can you please provide a reduced test case showing the problem?

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 7 years ago by Scott González

#8993 is a duplicate of this ticket.

comment:4 Changed 7 years ago by richalger

We are also experiencing this bug using jquery-1.8.3.min.js jquery-ui-1.9.2.custom.min.js jquery.uploadify-3.1.min.js

comment:5 in reply to:  4 Changed 7 years ago by tj.vantoll

Replying to richalger:

We are also experiencing this bug using jquery-1.8.3.min.js jquery-ui-1.9.2.custom.min.js jquery.uploadify-3.1.min.js

Please provide a reduced test case if you'd like us to look into this. You can use this to get started http://jsfiddle.net/tj_vantoll/tRdpr/.

comment:6 Changed 5 years ago by wmwong

I have created a simplified test case in JSFiddle to replicate this problem in IE9. http://jsfiddle.net/Hpkuw/

To replicate:

  1. Load the JSFiddle
  2. Click on SELECT FILES
  3. Note that a file browser shows up
  4. Click Cancel
  5. Click on the datepicker
  6. Click off of the datepicker
  7. Click on SELECT FILES again

Expected: The file browser shows up

Actual: The file browser does not show up and instead, the console shows the following error: "SCRIPT5022: Missing instance data for this datepicker".

Note that the duplicate ticket #8993 may have already provided an answer as to why this is happening.

comment:7 in reply to:  6 ; Changed 5 years ago by tj.vantoll

Replying to wmwong:

I have created a simplified test case in JSFiddle to replicate this problem in IE9. http://jsfiddle.net/Hpkuw/

To replicate:

  1. Load the JSFiddle
  2. Click on SELECT FILES
  3. Note that a file browser shows up
  4. Click Cancel
  5. Click on the datepicker
  6. Click off of the datepicker
  7. Click on SELECT FILES again

Expected: The file browser shows up

Actual: The file browser does not show up and instead, the console shows the following error: "SCRIPT5022: Missing instance data for this datepicker".

Note that the duplicate ticket #8993 may have already provided an answer as to why this is happening.

I'm trying to recreate this, but when I click on "Browse" on that fiddle in IE9 nothing happens. The script works fine in Chrome.

comment:8 in reply to:  7 ; Changed 5 years ago by wmwong

Do you see Browse or SELECT FILES?

When you say nothing happens, are you referring to step 2 or step 7?

Are you seeing anything in the console log?

If it helps, I'm using Browser Mode IE9 and Document Mode IE9 standards, version 9.0.8112.16421 on a Windows 7 machine.

comment:9 in reply to:  8 Changed 5 years ago by tj.vantoll

Replying to wmwong:

Do you see Browse or SELECT FILES?

When you say nothing happens, are you referring to step 2 or step 7?

Are you seeing anything in the console log?

If it helps, I'm using Browser Mode IE9 and Document Mode IE9 standards, version 9.0.8112.16421 on a Windows 7 machine.

Ok I see it now. Thanks for clarifying. To look into this we'd need an example that doesn't use an external plugin, because I'm not sure what would delete the datepicker's data, but the external plugin seems like the most likely culprit. Regardless, this won't be a problem in the rewrite (which is in progress now), so we're unlikely to do anything about this until then. If this is adversely affecting you I'd use some sort of monkey patch technique like the one from #8993.

Note: See TracTickets for help on using tickets.