Opened 7 years ago

Closed 7 years ago

#8451 closed bug (invalid)

Bad positionning calendar div on IE 9

Reported by: bchapoton Owned by: bchapoton
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8.21
Keywords: Cc:
Blocked by: Blocking:

Description

Hi, there is a bug with positioning of the calendar div with IE 9.0.8112.16421. When you place an input close enough to the right border of the browser, where it works with the other browser (Chrome, Firefox), the calendar div was displayed on the right beyond the scope of the window, instead replacing itself on left to show the entire calendar. Send me an email if you want some screenshot or some examples.

Here is a sample page where the problem comes, when you scale down the browser window width to the half of the datepicker input, then when you display the calendar, it's cut.

<html>
	<head>
		<title>Test date picker</title>
		<link type="text/css" href="css/ui-lightness/jquery-ui-1.8.21.custom.css" rel="stylesheet" />
		<script type="text/javascript" src="js/jquery-1.7.2.min.js"></script>
		<script type="text/javascript" src="js/jquery-ui-1.8.21.custom.min.js"></script>
		<script type="text/javascript">
			$(function(){
				$('#date').datepicker();
			});
		</script>
		<style>
			#date {
				margin-left: 600px;
			}
		</style>
	</head>
	<body>
		<form>
			<input type="text" id="date" />
		</form>
	</body>
</html>

Sorry for my english, I'm french.

Change History (4)

comment:1 Changed 7 years ago by maciejmrozinski

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.01.11.0

comment:3 Changed 7 years ago by mikesherov

Owner: set to bchapoton
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! I can't reproduce the issue using the information you've provided. Can you possibly attach a screenshot or link to one to show what you're talking about? Otherwise, I'll be unable to debug the issue further.

comment:4 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.