Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8488 closed bug (duplicate)

Dialog does not set text of generated buttons properly

Reported by: staticdream Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.21
Keywords: Cc:
Blocked by: Blocking:

Description

Using jquery 1.8 and jqueryui 1.8.22, dynamically generated buttons do not get their text assigned correctly.

eg. dialog button span's html does not get filled with button text. $("#confirm_dialog").dialog({

autoOpen: false, modal: true, width: 380, buttons: {

"Ok": function() {

$( this ).dialog( "close" );

}

}

}); fix for bug where button text never gets assigned to dialog buttons $("#confirm_dialog").parent().find("button[text='Ok']").find("span").html("Ok");

Change History (2)

comment:1 Changed 6 years ago by Scott González

Component: ui.coreui.dialog
Resolution: duplicate
Status: newclosed

comment:2 Changed 6 years ago by Scott González

Duplicate of #8484.

Note: See TracTickets for help on using tickets.