Opened 8 years ago

Closed 8 years ago

#8503 closed bug (notabug)

Sortable stack the ie9 randomly in jquery-ui-1.8.23

Reported by: alex Owned by: alex
Priority: minor Milestone: 1.9.0
Component: ui.sortable Version: 1.8.23
Keywords: Cc:
Blocked by: Blocking:

Description

I have a sortable on my page, before 1.8.23 I had jquery-ui-1.8.21 and jquery 1.7.2 and all worked just fine, after I started to use jquery ui-1.8.23 and jquery 1.8.0 while randomly dragging the portlets the internet explorer just started to randomly stack and I get "the internet explorer not responding due o a long running script" and then I get exception of jquery-1.8.0 line 2, col 75332 ch 75332

{return bL.test((b&&a.currentStyle?a.currentStyle.filter:a.style.filter)
"")?.01*parseFloat(RegExp.$1)+"":b?"1":""}

I have IE9 with compatibility mode to IE8

Thanks

Change History (11)

comment:1 Changed 8 years ago by Scott González

Owner: set to alex
Status: newpending

I'm not seeing this error with our portlets demo. Can you provide a reduced test case showing the problem?

comment:2 Changed 8 years ago by alex

Status: pendingnew

Hi, I'm providing you the demo project + swf video you can see the problem on my machine, when it stacks the cpu jumps to 100%. It does happens by 2 conditions: 1) The browser compatibility set to IE8 - <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" /> 2) Using jquery-1.8.0.js (if I use jquery-1.7.2.min.js all is working well)

Please run and the see the swf first for seeing the bug.

Thanks

www.avgraphics.co.il/jquery/index.html - video

www.avgraphics.co.il/jquery/3.swf - video

www.avgraphics.co.il/jquery/bug.rar - project

comment:3 Changed 8 years ago by Scott González

Status: newpending

Please provide a live demo, preferably using jsbin or jsFiddle, not a rar that must be downloaded and extracted. Thanks.

comment:4 Changed 8 years ago by alex

Status: pendingnew

Sorry, I don't know how to use jsbin or jsFiddle, never used it, I'm a new developer. I just found a bug in jquery UI and thought I may contribute to the community.

comment:5 Changed 8 years ago by Scott González

Status: newpending

You just write code, it's pretty straight forward. Here's a starting point: http://jsbin.com/ibaguj/1/edit

comment:6 Changed 8 years ago by alex

Status: pendingnew

Here it is, but i can't make it draggable, Maybe I need to add more reference? http://jsbin.com/ibaguj/3/

comment:7 Changed 8 years ago by Scott González

Status: newpending

There are a few problems here:

  • You're loading jQuery UI 1.8.13.
  • You're trying to load everything twice and the second set of references don't exist.
  • This is overlay complex.

Either provide a reduced test case showing the problem or ask for help on the forums.

comment:8 Changed 8 years ago by alex

Status: pendingnew

Here It is: http://jsbin.com/ibaguj/6 Just make sure you are in a compatibility mode of IE8 (should be by default as I inserted meta EmulateIE8) Anyway please clean your cache before tring it.

Stacks after dragging it randomly and fast

comment:9 Changed 8 years ago by Scott González

Status: newpending

After removing your code that's not actually related to the sortable plugin, I do not see the problem: http://jsbin.com/ibaguj/9/edit

Again, either provide a reduced test case showing that sortable is the cause of the problem or ask for help on the forums or StackOverflow.

comment:10 Changed 8 years ago by alex

Status: pendingnew

Sorry for miss understanding, but I thought if the simple jquery code like mouseenter and mouseleave stacks with jquery ui then it must be a jquery UI bug. Do you think should I forward i to jquery support team?

comment:11 Changed 8 years ago by Scott González

Resolution: invalid
Status: newclosed

You should analyze your code to figure out what you're doing that's causing the spikes. It's probably related to all of the animations you're running.

Note: See TracTickets for help on using tickets.