Opened 7 years ago

Closed 7 years ago

#8533 closed bug (notabug)

Easing: "swing" not equal to "easeOutQuad" anymore

Reported by: Hector Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.effects.core Version: 1.8.23
Keywords: Cc:
Blocked by: Blocking:

Description

Consistent in 1.8.18+/jQuery 1.7.x (not tested in previous) and until 1.8.22/jQuery 1.8.0, but in 1.8.23/jQuery 1.8.0 "swing" doesn't correspond to the easeOutQuad easing function anymore, at least for .animate()

Simple test:

<div style="border: 1px solid red; height: 50px; width: 0px;"></div>

$(function() {

$("div").animate({width: 1000}, 3000, "swing");

});

If you test that code in 2 parallel iframes, one with 1.8.22 and one with 1.8.23, the easing difference is obvious.

Change History (1)

comment:1 Changed 7 years ago by Scott González

Component: ui.coreeffects.core
Resolution: invalid
Status: newclosed

This is not a bug. The fact that we used to override swing is a bug. If you want easeOutQuad, use it.

Note: See TracTickets for help on using tickets.