Opened 7 years ago

Closed 7 years ago

#8540 closed feature (duplicate)

New Sortable option to specify horizontal or vertical floating mode

Reported by: pierre_taillard Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.21
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

I could be a little but useful feature: Give (to the sortable's user) the possibility to specify horizontal or vertical floating mode when creating sortable widget.

When you don't want to have items when sortable is initialized, floating mode is set by default to vertical : jquery.ui.sortable.js - line 53 this.floating = this.items.length ? (/left|right/).test(this.items[0].item.css('float')) : false;

Maybe an new option ('floating') which overrides the computing floating mode above should be helpful for addressing this case.

Regards

Change History (3)

comment:1 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:2 Changed 7 years ago by Jörn Zaefferer

Status: newopen

Consider for redesign.

comment:3 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: openclosed

Duplicate of #7498.

Note: See TracTickets for help on using tickets.