Opened 7 years ago

Closed 7 years ago

#8550 closed bug (fixed)

ThemeRoller doesn't work properly in IE7.

Reported by: snb Owned by: jquery-infrastructure
Priority: minor Milestone: 1.9.0
Component: [meta] ui.themeroller Version:
Keywords: Cc:
Blocked by: Blocking:

Description

ThemeRoller (http://jqueryui.com/themeroller/) doesn't work properly in IE7 (or in IE8/IE9 in the Compability Mode). The problem is raised by jQuery code on the following line in ThemeRoller the app.js:

$('#themeRoller form').bind('change', function() {

This code raises an exception in jQuery code. I've investigated this problem and found that there are 2 different tags in HTML with one ID: body tag with ID="themeroller" and DIV tag with ID="themeRoller". Selecting the FORM tag inside tag with ID="themeRoller" works fine in the IE8/IE9, but not in the IE7 because of different code branches in jQuery internal code.

This bug will go away if you change the ID attribute of the body tag from "themeroller" to some other value. Can you change ID of body tag?

Previously there wasn't such problems, so it looks like that either the body tag or the div tag got new ID value recently.

Change History (1)

comment:1 Changed 7 years ago by Scott González

Resolution: fixed
Status: newclosed

This is fixed in the new ThemeRoller.

Note: See TracTickets for help on using tickets.