Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8587 closed bug (notabug)

button keeps hover state in firefox

Reported by: sfornengo Owned by: sfornengo
Priority: minor Milestone: 1.9.0
Component: ui.button Version: 1.8.23
Keywords: Cc:
Blocked by: Blocking:

Description

see http://jsfiddle.net/nrYVk/ no problem in chromium

Change History (5)

comment:1 Changed 7 years ago by Scott González

Owner: set to sfornengo
Status: newpending

I have no idea what you're trying to show with detaching and appending the buttons on every click, but I assume you're referring to #7856.

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 7 years ago by sfornengo

this jsfiddle code swaps 2 buttons on every click, but I wrote a more simple test here: http://jsfiddle.net/nrYVk/2/ under firefox the hover state is kept after moving while the mouse pointer is no longer on the button. under chromium the hover state disappears as expected after the click. everything happens as if firefox does not generate the mouseleave event when the button is moved...

comment:4 Changed 7 years ago by sfornengo

sorry, use this updated testcase: http://jsfiddle.net/nrYVk/3/

comment:5 Changed 7 years ago by Scott González

Confirmed that this is exactly the bug I pointed you to earlier. http://jsfiddle.net/nrYVk/4/

Note: See TracTickets for help on using tickets.