Opened 8 years ago

Closed 8 years ago

#8588 closed bug (duplicate)

Draggable constraint breaking on some browsers when used with resizable

Reported by: Myndale Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.draggable Version: 1.8.23
Keywords: Cc:
Blocked by: Blocking:

Description

The example provided below displays a blue draggable and resizeable child rectangle inside a parent constraint. Attempting to drag the child rectangle to the far right initially causes correct behaviour i.e. the parent constrains the child's position, but following this with repeated click-and-drags causes the child to break the constraint on some browsers. Interesting, once the constraint has been broken it is broken across that same area permanently. Any attempt to resize the child by using the west/east handles immediately "fixes" the problem and the child constrains normally. Also this bug only occurs when the #child's position style option is set to 'absolute', setting it to 'fixed' appears to make the problem disappear.

Example of the bug in action here:

http://jsfiddle.net/CSWDU/1/

I've reproduced this on Safari 5.1 (7534.50) and Google Chrome (21.0.1180.89).

Change History (2)

comment:1 Changed 8 years ago by Scott González

Milestone: 1.9.02.0.0

comment:2 Changed 8 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #7106.

Note: See TracTickets for help on using tickets.