Opened 7 years ago

Closed 7 years ago

#8621 closed bug (duplicate)

Sortable: dragging does not work when items have different heights

Reported by: bdwain Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.24
Keywords: Cc:
Blocked by: Blocking:

Description

example of the problem here: http://jsfiddle.net/ADyhR/12/

when items in a sortable are different heights, sorting them causes all sorts of issues. As soon as you drag the item, the container shrinks because it is no longer inside of it. the placeholder does not fill the old space correctly. Manually setting the height prevents the container from shrinking, but the library code still expects the placeholder to be its original height.

these issues prevent things from working correctly when using the containment option. you can't drag taller items to the edges of the container.

Change History (4)

comment:1 Changed 7 years ago by bdwain

also, it seems to work in 1.8.9

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 7 years ago by petersendidit

Status: newopen
Summary: jquery sortable draggining not working correctly with different heightsSortable: dragging does not work when items have different heights

comment:4 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: openclosed

Duplicate of #4428.

Note: See TracTickets for help on using tickets.