Opened 7 years ago

Closed 7 years ago

#8630 closed bug (duplicate)

Changing/setting connectWith option on start event not kicking in right away

Reported by: marventus.wp Owned by:
Priority: minor Milestone: 1.9.1
Component: ui.sortable Version: 1.8.24
Keywords: Cc:
Blocked by: Blocking:

Description

Hello. While working with 3 sortable lists, I came up with the following problem, but not 100% sure if it's a but or intended behavior.

In my example, items in lists 1 and 3 can be sorted inside their respective lists and connect with list 2 only. For example, list 1 connects with list 1 and list2 and not list 3.

When list1 and list3 items are dropped inside list2, I needed for that rule to still apply, so I tried to change list2's connectWith option on the sortstart event. However, the result is not the one I was expecting, since the item first needs to be dropped in the source list (i.e., list2) before the start function kicks in. This also seems to occur with the sort event as well.

Example of issue: http://jsfiddle.net/Marventus/Ud69M/

Expected behavior: http://jsfiddle.net/Marventus/Ud69M/1/

Change History (4)

comment:1 Changed 7 years ago by Scott González

Resolution: invalid
Status: newclosed

This is not a bug. You can't wait until after the targets are determined to update the target.

comment:2 Changed 7 years ago by marventus.wp

If you don't want to call it a "bug", call it a feature if you like. Being able to bind list items to their original sortables would be a nice feature, since I don't see any other way of doing this with the current specs. I am of course open to the possibility I may be missing something.

Last edited 7 years ago by marventus.wp (previous) (diff)

comment:3 Changed 7 years ago by Scott González

Resolution: invalid
Status: closedreopened

comment:4 Changed 7 years ago by Scott González

Resolution: duplicate
Status: reopenedclosed

Duplicate of #7590.

Note: See TracTickets for help on using tickets.