Opened 7 years ago

Closed 7 years ago

#8631 closed bug (invalid)

closestHandler not always assigned

Reported by: jvm Owned by: jvm
Priority: minor Milestone: 1.9.1
Component: ui.slider Version: 1.8.24
Keywords: Cc:
Blocked by: Blocking:

Description

With multiple sliders on one page I got an "addClass on undefined object" error in Chrome on clicking the handler, even while the slider was correctly initialized. With Firefox and unminified code it tracked down to closestHandler not being assigned. I had trouble to always reproduce the problem, and am not aware of the cause. Googling brought me to this person, that recently described the problem, but apparently did not put it in the bug tracker:

https://gist.github.com/3745667

The fix works for me. Tested in 1.8.23 and 1.8.24.

Change History (2)

comment:1 Changed 7 years ago by Scott González

Owner: set to jvm
Status: newpending

Please provide a reduced test case showing the problem. Also, if you'd like to submit a patch, the proper method is a GitHub pull request, not a gist. Thanks.

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.