Opened 6 years ago

Closed 6 years ago

#8674 closed feature (invalid)

Adding a case option to intersect

Reported by: larsstorm Owned by: larsstorm
Priority: minor Milestone: 1.10.0
Component: ui.droppable Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

When working with ui.droppable on draggable objects using the snap function, there is a difficulty with the intersect touch case - to solve this I suggest a new case that only resolves true when the intersect is 'just' inside the droppable object.

Something like this: (naming of the case could use some work :) )

case "insidetouch":
	return i - 1 < e + b.helperProportions.width && f - b.helperProportions.width < j - 1 && k + 1 < g + b.helperProportions.height && h + 1 - b.helperProportions.height < l;

Change History (2)

comment:1 Changed 6 years ago by Scott González

Owner: set to larsstorm
Status: newpending
Version: 1.9.0

Please explain in words what the problem is and what your solution is.

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.