Opened 7 years ago

Closed 7 years ago

#8681 closed bug (duplicate)

DatePicker - Done Button stealing focus

Reported by: adondero@… Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.datepicker Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

When the user presses the done button, the focus is not placed back into the text box that the date picker is associated with, so tabbing to the next field does not work as expected. After pressing the done button, the user hits tab and focus it put back into the text box which causes the picker to display again (we have it displaying the calendar control on got focus).

Note: when clicking dates in the date picker portion of the div, does not steal focus from the text box.

I know this has existed in 1.8.1. We just upgraded to 1.9.0 to see if it was missing.

it happens here.. http://jqueryui.com/datepicker/ select the "Display Button Bar on the right hand side.

Change History (2)

comment:1 Changed 7 years ago by adondero@…

I am also using this control in combination with the TimePicker addon

http://trentrichardson.com/examples/timepicker/

comment:2 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #7765.

Note: See TracTickets for help on using tickets.