Opened 7 years ago

Closed 7 years ago

#8733 closed bug (duplicate)

Problem with collision FLIP on the bottom in iframe

Reported by: Deocarlos Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.position Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

Hello.

I'm using the component "Autocomplete" along with the "Position" to avoid collisions. In the code that I used in jsFiddle it is possible to view the bug.

The bug only occurs when it is used within an IFRAME and the "collision: flip" when collision occurs on the bottom iframe. When not using an IFRAME or the overflow occurs in on top, the two types of "collision" (fit and flip) are normal.

This bug started happening when I updated the latest versions of jQuery and jQueryUI. Before upgrading, I was using jquery-1.7.2.min.js and jquery-ui-1.8.20.custom.min.js and was working properly, using inside or outside the iframe.

THIS IS PROBLEM: jquery-1.8.2.min.js and jquery-ui-1.9.0 ==> http://jsfiddle.net/sqRDj/1/

THIS IS OK: jquery-1.7.2.min.js and jquery-ui-1.8.20 ==> http://jsfiddle.net/sqRDj

This is screenshot of my project (The window opened is one iframe):

With position FIT is problem: http://s10.postimage.org/txakha1e1/position_flip.png

With position FIT is ok: http://s8.postimage.org/kyxeu6f85/position_fit.png

Change History (1)

comment:1 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #8710.

Note: See TracTickets for help on using tickets.