Opened 7 years ago

Closed 7 years ago

#8764 closed bug (wontfix)

Tooltip does not disappear if the the element the tooltip is on opens a dialog

Reported by: weasel423 Owned by: weasel423
Priority: minor Milestone: 1.10.0
Component: ui.tooltip Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

If you have an element that opens a dialog ui, and it has a tooltip (title - such as on a button), the tooltip does not disappear when the dialog is opened, and the tooltip stays on the page until you refresh

Change History (3)

comment:1 Changed 7 years ago by tj.vantoll

Owner: set to weasel423
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket. This works fine for me - http://jsfiddle.net/tj_vantoll/avP5K/.

comment:2 Changed 7 years ago by weasel423

Status: pendingnew

I figured out why I was getting the issue I described (double initialization of a ui-icon element).

However, while trying to duplicate this issue on jsFiddle, I discovered another related bug with the tooltip/dialog elements. http://jsfiddle.net/avP5K/9/

Please note that when you click the pencil (edit) button, and there is a link in the dialog box, and the link is the first element with a "tab index", it gets highlighted by default causing the tooltip to display.

This is also an issue when you have a tooltip on a link to downloadable content (for example: a csv file) because after you click on the link and the "save/open" dialog comes up, the link is still highlighted so the tooltip displays until you click elsewhere on the page.

comment:3 Changed 7 years ago by tj.vantoll

Resolution: wontfix
Status: newclosed

Giving focus to the first focusable element is intended behavior of the dialog widget. If you need to set focus to another element use the open event to change it - http://jsfiddle.net/tj_vantoll/Mdshr/.

I don't really see the fact that the tooltip doesn't go away when the browser's "Save As" dialog comes up as a problem. The tooltip could provide context on what the file is that could help in dealing with the dialog. If you really need the tooltip to go away under these circumstances you could attach a click event to the link and explicitly close it.

Note: See TracTickets for help on using tickets.