Opened 7 years ago

Closed 7 years ago

#8771 closed bug (notabug)

jquery-ui-dialog-extra gives error when used with jQuery-ui-1.9.1

Reported by: satyamtallam Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.dialog Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

I am using jQuery-ui-dialog-extra to add minimize/maximize/restore buttons to a standard jQuery UI dialog. Its was working perfect when I was using jQuery-ui-1.8.16.Now I have upgraded the jQuery-ui from jQuery-ui-1.8.16 to jQuery-ui-1.9.1 .

Now the problem is when I click 'minimize' button of dialog, then dialog is minimized.But when I click 'maximize' button to restore the size and position the dialog remain as it is and an error is displayed on console: Uncaught Error: no such method '_generatePosition' for draggable widget instance.

For more understanding please look into http://jsfiddle.net/S4LzA/5/

Please let me know how to solve this issue.Thanks in advance.

Change History (1)

comment:1 Changed 7 years ago by Jörn Zaefferer

Resolution: notabug
Status: newclosed

This is a bug in jquery-ui-dialog-extra: https://github.com/jsmarkus/jquery-ui-dialog-extra

Usually I'd say report the issue there, but it says there "I don't maintain this project anymore. I decided to move it to GitHub to give other people an ability to fork it and use it."

The addon is using dialog-internal methods that changed from 1.8 to 1.9, which is normal for internal private methods. You'd need to find someone to update the addon to work with 1.9, or do it yourself.

Note: See TracTickets for help on using tickets.