Opened 7 years ago

Closed 7 years ago

#8818 closed bug (duplicate)

jQuery UI CSS includes data-URI, causes error message over HTTPS for IE6&7

Reported by: KeithHenry Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.resizable Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

There appears to be a bug introduced by the fix for http://bugs.jqueryui.com/ticket/7233#comment:15

The problem is this block of code:

.ui-resizable-handle { position: absolute;font-size: 0.1px;z-index: 99999; display: block;
    /* http://bugs.jqueryui.com/ticket/7233
     - Resizable: resizable handles fail to work in IE if transparent and content overlaps
    */
    background-image:url(data:image/gif;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs=);
}

IE6 & 7 don't support data-URIs in CSS, but the problem is that IE6 & 7 also consider them to always be non-secure, so any HTTPS users on IE6 or 7 get an error message:

This page contains both secure and nonsecure items Do you want to display the nonsecure items?

Change History (1)

comment:1 Changed 7 years ago by Scott González

Component: ui.dialogui.resizable
Resolution: duplicate
Status: newclosed

Duplicate of #7390.
Please test against the latest version of jQuery UI before reporting bugs. This was fixed a dozen versions ago.

Note: See TracTickets for help on using tickets.