Opened 7 years ago

Closed 7 years ago

#8829 closed bug (duplicate)

Disabling should clear ui-state-hover class

Reported by: ezyang Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.button Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

See http://jsfiddle.net/R8xCe/ (click on the button; expected results: class does not include ui-state-hover; actual result: class contains ui-state-hover)

When a button gets disabled, it should not be treated as being hovered upon. In particular, the onmouseout handler no longer is installed so removing your mouse won't remove the hover state, and if you re-enable the button at a later point, it will be spuriously highlighted. This is bad!

Change History (1)

comment:1 Changed 7 years ago by Scott González

Component: ui.coreui.button
Resolution: duplicate
Status: newclosed

Duplicate of #5295.

Note: See TracTickets for help on using tickets.