Opened 7 years ago

Closed 7 years ago

#8837 closed bug (wontfix)

Dialog: Select Unclickable in Windows Firefox 16

Reported by: dmadouros Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.dialog Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

We have a form with a select and a dialog also containing a select. The body's overflow is set to 'hidden' in the on open function. When we click the dialog, the select element is unclickable and the options do not dropdown. We have been able to reproduce this in Firefox 16.0.1 and Firefox 16.0.2 on Windows 7. We are unable to reproduce this issue in Firefox 15.0.1, IE 8, IE 9 (version 9.0.8112.16241) and Google Chrome (version 23.0.1271.64 m). We are using JQuery 1.8.3 and JQuery UI 1.9.1.

Here is a small testcase that reproduces the problem in Firefox 16.0.1 and 16.0.2: http://jsfiddle.net/qssC7/

Setting the body's overflow to hidden is necessary for us to support IE. For more details, please see: http://forum.jquery.com/topic/opening-a-modal-dialog-shows-a-horizontal-scroll-bar

Change History (5)

comment:1 Changed 7 years ago by tj.vantoll

Status: newopen
Summary: SELECT DROPDOWN BOX UNCLICKABLE IN FIREFOX 16.0.1/16.0.2Dialog: Select Unclickable in Windows Firefox 16

Confirmed and minified - http://jsfiddle.net/tj_vantoll/eUw7d/15/. This is a bizarre one that I think is likely a Firefox bug.

  • I can only get the issue to happen on Firefox 16 on Windows. It works fine in Firefox 15. It works fine in Firefox 16 on OS X. I also do not see the issue in any of the other browser combinations I've tried.
  • Another <select> needs to be present for the bug to occur. If I remove the other <select> this issue does not occur. It's like ui.dialog's code is giving the other <select> focus and the modal logic is keeping anything else from getting focus.
  • As mentioned the <body>'s overflow must be changed to hidden.

comment:2 Changed 7 years ago by Jörn Zaefferer

tj_vantoll confirmed its still a problem in master.

comment:3 Changed 7 years ago by k_borchers

I am no longer able to reproduce this issue. Can anyone confirm?

comment:4 Changed 7 years ago by tj.vantoll

I can still see the issue in Firefox 16 on Windows 7 on http://jsfiddle.net/tj_vantoll/eUw7d/15/show.

Odd but I do not see the issue at http://jsfiddle.net/tj_vantoll/eUw7d/15/ in jsFiddle anymore, but if I see view the "/show" I do.

comment:5 Changed 7 years ago by tj.vantoll

Resolution: wontfix
Status: openclosed

Ah I see. I cannot recreate the problem in Firefox 17, so it looks like they fixed whatever the issue was on their end. Since that's two of us I'll resolve this as wontfix. If someone else can recreate this let us know.

Note: See TracTickets for help on using tickets.