Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8856 closed bug (worksforme)

Draggable with iframeFix Option - freezes during drag on IE9 with IE8 Standards/ IE8 Document mode

Reported by: tmcconechy Owned by: tmcconechy
Priority: minor Milestone: 1.10.0
Component: ui.draggable Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

This issue can be reproduced in both 1.9.1 and 1.8. Please see the following jsFiddle:

  • Open this page in IE9 : http://jsfiddle.net/D2SSx/
  • Hit F12 and change both the Browser mode and document mode to 8.
  • drag the red bar up and down over the iFrames. try this a couple of times dragging up and down.

It will eventually not be possible to drag over the iFrame as expected after one or two up and down drags..

The following code seems to fix the issue added to draggable._mouseCapture

$(o.iframeFix === true ? "iframe" : o.iframeFix).each(function() {
			$('<div class="ui-draggable-iframeFix" style="background: transparent;"></div>')
			.css({
				width: this.offsetWidth+"px", height: this.offsetHeight+"px",
				position: "absolute", zIndex: 100000
			})
			.css($(this).offset())
			.appendTo("body");
		});

It might be related to the weird IE alpha filters on opacity.

Change History (8)

comment:1 Changed 7 years ago by tj.vantoll

Owner: set to tmcconechy
Status: newpending

Hi tmcconechy. Thanks for taking the time to contribute to the jQuery UI project.

The test case you provided is using an old version of jQuery UI. Please test against the latest version to make sure the issue still exists. You can use this as a starting point - http://jsfiddle.net/ZgAqH/.

Thanks.

comment:2 Changed 7 years ago by tmcconechy

Status: pendingnew

Hi Tj, I updated the fiddle you started http://jsfiddle.net/tmcconechy/hQYPK/2/ it still exhibits the problem.

Thanks!

comment:3 Changed 7 years ago by tj.vantoll

I've tried this a few times and I'm still not able to recreate this.

comment:4 Changed 7 years ago by tmcconechy

The issue cannot be reproduced on IE8. Only in IE9 (or IE10) with Browser Mode = 8 and Document Mode = IE8 Standards.

Seems to happen right away if i drag the bar up about half way over the top iframe and then down - where it stops as it hits the lower iframe...

Also I did verify again just now with another developer.

I hope that helps..?

comment:5 Changed 7 years ago by Scott González

Resolution: worksforme
Status: newclosed

We've had multiple people test this on multiple installs and nobody on the team can reproduce this. Unfortunately, there's nothing we can do if we can't reproduce the bug.

comment:6 Changed 7 years ago by Muniju

Hi. I was able to reproduce this. When you drag the red bar, drag it all the way up until it can't go any further, but also notice that you see blue squares appear to the right-bottom of each iframe. I believe these are the selection marking, like when you select a part of a page. When those appear, you cannot drag the red bar back down. However, if you now click on the blank space to the right of the iframes, you can then drag the bar again (It didn't work when I clicked on the iframes themselves).

BTW, I noticed another thing - when I drag the red bar downwards until a scrollbar appears, and then drag it upwards a bit, the bar disappears. It jumps to the very bottom. Then, when I drag it (From the bottom) upwards a bit, it again disappears, and jumps back up with the iframes. Notice you may not see it after it jumps up. To see it, I drag it only slightly upwards. This happens also in Firefox and Chrome, though the bar may jump a bit differently.

comment:7 in reply to:  6 Changed 7 years ago by tj.vantoll

Replying to Muniju:

Hi. I was able to reproduce this. When you drag the red bar, drag it all the way up until it can't go any further, but also notice that you see blue squares appear to the right-bottom of each iframe. I believe these are the selection marking, like when you select a part of a page. When those appear, you cannot drag the red bar back down. However, if you now click on the blank space to the right of the iframes, you can then drag the bar again (It didn't work when I clicked on the iframes themselves).

BTW, I noticed another thing - when I drag the red bar downwards until a scrollbar appears, and then drag it upwards a bit, the bar disappears. It jumps to the very bottom. Then, when I drag it (From the bottom) upwards a bit, it again disappears, and jumps back up with the iframes. Notice you may not see it after it jumps up. To see it, I drag it only slightly upwards. This happens also in Firefox and Chrome, though the bar may jump a bit differently.

I tried one more time and still cannot recreate the IE9 in IE8 document mode issue. I can see the issue with the scrolling but I believe that is already covered by #6817.

comment:8 Changed 7 years ago by Muniju

Just one more thing - I forgot to mention that after dragging the bar up until seeing the blue squares, I release the mouse button. The problem occurs when trying to drag the bar *again*, this time back down. Sorry for that.

Note: See TracTickets for help on using tickets.