Opened 7 years ago

Closed 6 years ago

#8881 closed bug (duplicate)

$('#element').resizable triggers $(window).resize on change

Reported by: kavisiegel Owned by:
Priority: minor Milestone:
Component: ui.resizable Version: 1.9.2
Keywords: Cc:
Blocked by: Blocking:

Description

This bug has been present in every version of JQueryUI since 1.6.0 - before 1.6.0 there was no 'resize' callback option. In 1.5.3, neither the $(window).resize or resize callback are run.

Scenario: you have a function bound to $(window).resize. You resize a JQueryUI.resizable object. Both functions are run.

Here's a fiddle: http://jsfiddle.net/WphwV/3/

Change History (3)

comment:1 Changed 7 years ago by Scott González

Resolution: notabug
Status: newclosed

This is not a bug, events bubble up to the window. http://bugs.jquery.com/ticket/9841

In the future, we will change our widget event types to never collide with native event types.

comment:2 Changed 6 years ago by Scott González

Milestone: 1.10.0
Resolution: notabug
Status: closedreopened

comment:3 Changed 6 years ago by Scott González

Resolution: duplicate
Status: reopenedclosed

Duplicate of #7514.

Note: See TracTickets for help on using tickets.