Opened 7 years ago

Closed 7 years ago

#8899 closed bug (duplicate)

Datepicker: When current date is not in yearRange date's in range cannot be selected

Reported by: wbednarski Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.9.2
Keywords: Cc:
Blocked by: Blocking:

Description

Assuming following code:

datePickerInput.datepicker({
        yearRange: '-100:-18',
        changeMonth: true,
        changeYear:  true
    });

Click on the input, I see datepicker dated on 11 December 1912 (today is 11 December 2012), then I click on any day, lets say 29 and input is populated by 12/29/2012 which is obviously different date I was expected to be.

You can see it here – http://jsfiddle.net/wbednarski/45mLv/

Change History (1)

comment:1 Changed 7 years ago by tj.vantoll

Milestone: 1.10.01.11.0
Resolution: duplicate
Status: newclosed
Summary: Datepicker date range issueDatepicker: When current date is not in yearRange date's in range cannot be selected

Duplicate of #8873.
Hi wbednarski, thanks for taking the time to contribute to the jQuery UI project. This issue appears to be the same problem as #8873 so I'm going to close this one as a duplicate and include your test case there.

Thanks!

Note: See TracTickets for help on using tickets.