Opened 7 years ago

Closed 7 years ago

#8944 closed bug (duplicate)

Firefox Bug using Draggable with containment

Reported by: andreas.marschke Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.draggable Version: 1.9.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hi!

When using draggable on an element in firefox with a cancel element and containment the draggable element either sticks to moving left or right or even moves to top:-XXpx; making it impossible to use.

Here is a jsfiddle: http://jsfiddle.net/eDXWz/1/ Additionally here is a larger project where the same bug happens:

https://github.com/andreas-marschke/mockup-dashboard-designer

This bug occurs in recent Firefox versions on all plattforms.

It has no version affinity as can be seen in the fiddle.

Chrom(e/ium) is not affected by this.

Change History (1)

comment:1 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #8940.
Hi, andreas.marschke,

Thanks for taking the time to contribute to the jQuery UI project. Your issue is actually being caused because of containment: 'body' which is currently not supported by jQuery UI. If the containment is changed to "window" or "document" your example works fine - http://jsfiddle.net/tj_vantoll/dRy6t/.

Note: See TracTickets for help on using tickets.