Opened 7 years ago

Closed 7 years ago

#8963 closed bug (fixed)

Dialog: focus close button and closing dialog with Jaws 13.0.1006 64bit

Reported by: ssoorriiin Owned by: ssoorriiin
Priority: minor Milestone: 1.10.0
Component: ui.dialog Version: 1.9.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have a simple dialog with an Ok button.

  1. Jaws reads and identifies dialog's ok and close button
  2. Focus is not set to close button when is selected from list, instead is set to Ok button

Optional:

  1. Hit enter -> dialog closes
  2. Insert + F5 to read again the form fields -> Jaws identifies again the ok and close button even if dialog wasn't opened again

Something similar can be reproduced here (but for v. 1.8.3): http://view.jqueryui.com/dialog/demos/dialog/default.html

Change History (5)

comment:1 Changed 7 years ago by ssoorriiin

I've created a test case here: http://jsbin.com/welcome/74658/edit

  1. Insert + F5
  2. Choose "click Button"
  3. Enter -> sets focus to "click" button
  4. Enter -> dialog opens
  5. Insert + F5
  6. Choose "close Button"
  7. Enter -> dialog closes
  8. Insert + F5 -> issue: Jaws reads close and ok buttons instead of reading entire page (in this case consisted only of "click" button)

comment:2 Changed 7 years ago by Scott González

Owner: set to ssoorriiin
Status: newpending

Could you please remove anything unrelated to the bug from that test case? I'm not sure what all that JavaScript is for, or why you need any CSS at all. Also, can you please test with 1.10.0-rc.1 or master to see if the problem still exists? We've made a lot of changes to dialog.

1.10.0-rc.1: [js http://code.jquery.com/ui/1.10.0-rc.1/jquery-ui.js], [css http://code.jquery.com/ui/1.10.0-rc.1/themes/base/jquery-ui.css]
master: [js http://code.jquery.com/ui/jquery-ui-git.js], [css http://code.jquery.com/ui/jquery-ui-git.css]

Version 1, edited 7 years ago by Scott González (previous) (next) (diff)

comment:3 Changed 7 years ago by ssoorriiin

Status: pendingnew

I've updated test case: http://jsbin.com/okekeg/1/edit Looks like issue is solved with 1.10.0-rc.1, leaving me to update my 3rd party.

Thanks.

comment:4 Changed 7 years ago by ssoorriiin

Here is test case for version 1.9.2: http://jsbin.com/okekeg/2/edit where issue reproduces. Until a new stable version is released, do you think there is a workaround for this?

Thanks in advance.

comment:5 Changed 7 years ago by Scott González

Milestone: none1.10.0
Resolution: fixed
Status: newclosed

That test case looks like it contains just as much unrelated code as the first test case. If it's working in 1.10.0-rc.1, then just wait for 1.10.0, it'll be released in a few days.

Note: See TracTickets for help on using tickets.