Opened 7 years ago

Closed 4 years ago

#8968 closed bug (wontfix)

Datepicker: month unselectable in popup window in IE8

Reported by: matf4 Owned by:
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.9.2
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery: 1.8.3 jQuery-ui: 1.9.2 component: datepicker

After initializing datepicker with month and year combo-boxes everything is working fine.

Problems appear when initializing the same datepicker in popup window (opened using window.open() function). Select date with month dropdown is impossible (selection dissapears right away), however it's possible to select year with dropdown so I consider it a bug in jquery.

jsFiddle: http://jsfiddle.net/j389R/6/ Bug is repeatable, it was confirmed with IE 8.0.6001.18702 and IE 8.0.7601.17514 and I'm sure this bug was also present in jquery-ui 1.7 and 1.8 This is not a duplicate of #6198 (doesn't have anything in common with double-clicking in IE).

Change History (4)

comment:1 Changed 7 years ago by tj.vantoll

Status: newopen
Summary: bug: datepicker month dropdown in popup window - IE8Datepicker: month unselectable in popup window in IE8
Version: 1.9.21.10.0-rc.1

Still trying to figure out what's going on here but I do see the bug, here's a reduced test case http://jsfiddle.net/tj_vantoll/j389R/23/. This issue is not present in IE9.

comment:2 Changed 7 years ago by tj.vantoll

Milestone: none1.11.0
Version: 1.10.0-rc.11.9.2

comment:3 Changed 5 years ago by Scott González

Milestone: 1.11.0none

comment:4 Changed 4 years ago by Scott González

Resolution: wontfix
Status: openclosed

IE 8 is no longer supported as of jQuery UI 1.12.0.

Note: See TracTickets for help on using tickets.