Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9025 closed bug (duplicate)

Autocomplete custom data bug

Reported by: dkynaston@… Owned by:
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.10.0
Keywords: Cc:
Blocked by: Blocking:

Description

get this error in our code and even on the demos page when trying to set custom data like:

.data( "autocomplete" )._renderItem = function( ul, item ) {

return $( "<li>" )

.append( "<a>" + item.label + "<br>" + item.desc + "</a>" ) .appendTo( ul );

};

Uncaught TypeError: Cannot set property '_renderItem' of undefined in cutom-data.html line 66.

Change History (3)

comment:1 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #8992.

comment:2 Changed 7 years ago by dkynaston@…

I get this is a duplicate issue of #8992, but this is no resolution. It was closed as "notabug" but the bug still exist on your own demo: http://jqueryui.com/autocomplete/#custom-data. What are we supposed to do here?

comment:3 Changed 7 years ago by Scott González

It'll be fixed with in about a week when the next release comes out.

Note: See TracTickets for help on using tickets.