Opened 7 years ago

Closed 7 years ago

#9032 closed bug (duplicate)

Dialog widget in v1.10 gets javascript error invoking destroy method

Reported by: rmzpfef Owned by:
Priority: minor Milestone: none
Component: ui.core Version: 1.10.0
Keywords: Cc:
Blocked by: Blocking:

Description

I create a dialog widget specifying autoopen false. I never open the dialog and call the destroy method. It gets an exception at line 9491 (not minned version): Cannot call method 'remove' of undefined. Statement is this.overlay.remove();

I know why it happens. It does not create the overlay until the dialog is opened. Since I never opened it on the destroy it tries to remove the overlay without checking if it was created.

This behavior is new for v1.10. It worked fin in v1.9.

Even setting the uiBackCompat to true does not fix this.

I will fix in my own copy. Please let me know if I am not using the destroy function properly.

Thank you

Change History (1)

comment:1 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #9004.

Note: See TracTickets for help on using tickets.