Opened 7 years ago

Closed 7 years ago

#9063 closed bug (duplicate)

Dialog: Scroll to top when dialog loses focus

Reported by: wayne Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.0
Keywords: Cc:
Blocked by: Blocking:

Description

Since jQuery UI 1.10.0 we're experiencing a problem with dialogs containing scrolling divs when more than one dialog is open. We have a minimal example of the problem scenario available at http://wkoorts.com/files/jqui-dialog-scroll-problem.html which loads the libraries via Google CDN.

To reproduce:

  1. Focus in one dialog and scroll the div down (partially or all the way gives the same result).
  2. Click anywhere in the 2nd dialog and the scrolling div in the first dialog will scroll to the top.

The same happens in reverse. Also, if both divs are scrolled down, they will both scroll to top.

Reverting to 1.9.2 fixes it.

Tested with Firefox, IE, Chrome and Opera on Windows 7. Breaks in these browsers:

  • Firefox 18.0.1
  • Internet Explorer 9.0.8112.16421
  • Chrome 24.0.1312.57

Not Broken only in Opera 12.13 build 1734

We're using jQuery 1.9.0

Change History (2)

comment:1 Changed 7 years ago by tj.vantoll

Status: newopen
Summary: Dialogs with scrolling divs - scroll to top when focusing in other dialogDialog: Scroll to top when dialog loses focus

Confirmed against master: http://jsfiddle.net/tj_vantoll/4UwNt/

comment:2 Changed 7 years ago by Scott González

Resolution: duplicate
Status: openclosed

Duplicate of #9166.
I'm closing this as a duplicate of #9166 even though this was filed first and the user-perceived issue is slightly different. I just want to use #9166 as a catch-all for issues related to changing the DOM in moveToTop().

Note: See TracTickets for help on using tickets.