Opened 7 years ago

Closed 7 years ago

#9065 closed bug (duplicate)

Dialog _size() and content sizing reset

Reported by: aNt1X Owned by:
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.0
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

inside the _size() function you perform a content sizing reset like this:

// Reset content sizing
		this.element.show().css({
			width: "auto",
			minHeight: 0,
			maxHeight: "none",
			height: 0
		});

So, if you open a new dialog, you will have the width property set to Auto.

But as soon as the user perform a resize of the dialog, because of the resizeAlso property, the content will be resized too, overwriting the AUTO width value.

The two behavaiours seems to collide a little.

The main problem i have, is when the content is an iframe, because the 'auto' width of iframe does not work.

I think it should be better to start with a width equal to the dialog width.

This would be more coherent with the following behaviours, and the resize will be ok.

What do u think?

Change History (1)

comment:1 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4066.

Note: See TracTickets for help on using tickets.