Opened 6 years ago

Closed 5 years ago

#9067 closed bug (duplicate)

New stacking feature causing iframe problems when changing active dialog

Reported by: aNt1X Owned by: aNt1X
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.0
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

Talking about the following commit:

https://github.com/jquery/jquery-ui/commit/3829a37ca122e923c3a08b964c4b1a946a2a1456

The new moveToTop() function breaks iframe usage because of this line of code:

var moved = this.uiDialog.nextAll( ":visible" ).insertBefore( this.uiDialog );

The insertBefore() usage makes the iframe to be detached and reattached from the DOM; you can have occasional javascript errors or entire iframe refresh, depending on which browser you use; i think it is because of this:

http://bugs.jquery.com/ticket/8533

What do u think?

I know it's not a jQuery ui problem, but how can we avoid this ?

Thank you for your work.

Change History (7)

comment:1 Changed 6 years ago by aNt1X

Sorry guys, i left the component setting of this ticket to "ui.core" but it is "ui.dialog".

Sorry again.

comment:2 Changed 6 years ago by Scott González

Component: ui.coreui.dialog
Owner: set to aNt1X
Status: newpending

I think browser vendors should fix this. Do you have any suggestions?

comment:3 Changed 6 years ago by aNt1X

Status: pendingnew

Not yet. I will further investigate it.

Vendors implemented this protection to avoid memory leaks (http://msdn.microsoft.com/en-us/library/gg622929(v=VS.85).aspx?ppud=4).

We could modify the z-index only for those dialogs that contains an iframe, leaving the new mechanism for dialogs without an iframe, but it would be an ugly workaround, and the old z-indexes method caused many problems ...

comment:4 Changed 6 years ago by mandana

I have the same problem after upgrading JqueryUI to 1.10 As there is no other way to move an ifram in DOM without loosing it's content, using z-index seems to be the only possible solution to this issue. BTW I don't think of it as a minor bug!!!

comment:5 Changed 6 years ago by mikesherov

Resolution: cantfix
Status: newclosed

Nothing we can do here... Although, fortunately, now jQuery has a meta ticket in webkit for issues we need fixed. This has been added.

Commented here: https://bugs.webkit.org/show_bug.cgi?id=13574 and noted as a blocker here: https://bugs.webkit.org/show_bug.cgi?id=110007

comment:6 Changed 5 years ago by Jörn Zaefferer

Resolution: cantfix
Status: closedreopened

This is a duplicate of #9166 (or the other way round), which we're addressing on our end, since browsers declared WONTFIX. So the cantfix solution isn't correct anymore.

comment:7 Changed 5 years ago by Jörn Zaefferer

Resolution: duplicate
Status: reopenedclosed

Duplicate of #9166.

Note: See TracTickets for help on using tickets.