Opened 7 years ago

Closed 6 years ago

#9173 closed bug (duplicate)

Dialog: Focus forced back to first focusable element in IE7/8

Reported by: andychin777 Owned by: andychin777
Priority: minor Milestone: none
Component: ui.dialog Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

Jquery-UI 1.10.2 code forces the first tab-able item in the dialog box to be focused on if an area outside of the dialog box DIV is selected.

This become troubling when trying to use ckeditor dropdown list. As dropdowns will be created outside of the dialog DIV and selected thus triggering the above event, making the drop downs impossible to be selected by the user.

The core issue can be shown in the examples below, (note: these do not contain CKEditor Code) Please view using Internet explorer 8, Viewing in other browsers may result in multiple prompt boxes appearing.

Jquery-ui-1.10.2 Version http://jsbin.com/oxoyop/1

Jquery-ui-1.9.2 Version http://jsbin.com/avapey/2

This seems more of a bug than a special feature as it only occurs in Internet explorer.

Cheers, Andrew

Change History (5)

comment:1 Changed 7 years ago by Scott González

Owner: set to andychin777
Status: newpending

We need an example that doesn't use alert() on focus.

comment:2 Changed 7 years ago by andychin777

Status: pendingnew

sure no problem.

Jquery-ui-1.10.2 Version. http://jsbin.com/asohow/2 Jquery-ui-1.9.2 Version. http://jsbin.com/uwajil/1

Removed the alert on focus and replaced the button with a dropdownbox so it can be easily seen that something is being selected.

Same rules apply as stated in bug.

Cheers, Andrew

comment:3 Changed 7 years ago by tj.vantoll

Status: newopen
Summary: Focus is forced back to first tabbable item in Internet explorer 8Dialog: Focus forced back to first focusable element in IE7/8

Verified and reduced http://jsbin.com/asohow/4/edit.

The behavior occurs in IE7 & IE8 but does not occur in IE9, IE10, Firefox, Chrome, Safari, or Opera.

comment:4 Changed 6 years ago by Jörn Zaefferer

From dialog's _keepFocus method: "IE <= 8 doesn't prevent moving focus even with event.preventDefault()". We force focus back inside the modal dialog, since we can't prevent the focus from getting lost inside the dialog in the first place.

The original ticket is about dropdowns outside the dialog, right? That seems to be a different issue, one to be addressed by _allowInteraction: http://api.jqueryui.com/dialog/#method-_allowInteraction

Last edited 6 years ago by Jörn Zaefferer (previous) (diff)

comment:5 Changed 6 years ago by Scott González

Resolution: duplicate
Status: openclosed

Duplicate of #9087.
Yeah, pretty much anything that involves CKEditor will be about _allowInteraction().

Note: See TracTickets for help on using tickets.