Opened 7 years ago

Closed 7 years ago

#9177 closed bug (duplicate)

Slight cursor movement causes button attached to checkbox not to toggle

Reported by: themooserooster Owned by:
Priority: minor Milestone: none
Component: ui.button Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

When a button is attached to a checkbox input element, if the cursor moves at all during the course of the click (from mousedown until mouseup) the button widget is not toggled. Most users will never notice this as the cursor is unlikely to move during this brief moment if the user is using a trackpad, touch interface, or mouse. Users with a very sensitive input device, such as a Wacom tablet, find the widget almost impossible to use. It can take many attempts at a click to actually toggle the widget. When tried with a touchpad or even the Wacom mouse, this problem never arises unless the user moves the cursor slightly during mousedown. I recommend a 5-7px threshhold for cusror movement before preventing a click event from bubbling.

Change History (1)

comment:1 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #7665.

Note: See TracTickets for help on using tickets.