Opened 7 years ago

Closed 6 years ago

#9188 closed bug (duplicate)

Draggable: Position in stop event is incorrectly with constrained draggables

Reported by: s512 Owned by:
Priority: minor Milestone: none
Component: ui.draggable Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/6X5nR/1/

Move the box in the example above and the input boxes are updated with position values. The box is set to be draggable on y axis only, but attempt to drag box to the right and the left value is updated despite the box not being able to move.

Change History (2)

comment:1 Changed 7 years ago by tj.vantoll

Status: newopen
Summary: Position in stop event is not updated according to element movementDraggable: Position in stop event is incorrectly with constrained draggables

Confirmed: http://jsfiddle.net/tj_vantoll/h8nRw/.

Looks like the its returning the mouse's position and the docs indicate it should be returning the "current CSS position of the helper" (http://api.jqueryui.com/draggable/#event-stop).

comment:2 Changed 6 years ago by mikesherov

Resolution: duplicate
Status: openclosed

Duplicate of #7251.

Note: See TracTickets for help on using tickets.